summary refs log tree commit diff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-26 21:35:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-26 23:13:54 +0100
commit68631e037bd79039b5b14150e01f64cd8f81eabb (patch)
treee915b9cdf73b61600416ac24d9e16f83911048e6 /gnu/packages/dlang.scm
parent4b81d5c4bc442a12c681586f6c25a4ca0af44056 (diff)
downloadguix-68631e037bd79039b5b14150e01f64cd8f81eabb.tar.gz
gnu: ldc: Use INVOKE.
* gnu/packages/dlang.scm (ldc)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index ddd747a156..c164ed849a 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -211,12 +211,12 @@ bootstrapping more recent compilers written in D.")
              (lambda* (#:key inputs #:allow-other-keys)
                (let ((unpack (lambda (source target)
                                (with-directory-excursion target
-                                 (zero? (system* "tar" "xvf"
-                                                 (assoc-ref inputs source)
-                                                 "--strip-components=1"))))))
-                 (and (unpack "phobos-src" "runtime/phobos")
-                      (unpack "druntime-src" "runtime/druntime")
-                      (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite")))))
+                                 (invoke "tar" "xvf"
+                                         (assoc-ref inputs source)
+                                         "--strip-components=1")))))
+                 (unpack "phobos-src" "runtime/phobos")
+                 (unpack "druntime-src" "runtime/druntime")
+                 (unpack "dmd-testsuite-src" "tests/d2/dmd-testsuite"))))
            (add-after 'unpack-submodule-sources 'patch-phobos
              (lambda* (#:key inputs #:allow-other-keys)
                (substitute* '("runtime/phobos/std/process.d"