summary refs log tree commit diff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-06-15 19:53:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-19 02:00:00 +0200
commit22e289a67ab6ce03c84c67c0ea20814ee912f643 (patch)
tree6188d89fdbcfaeea1c560120952941438263abad /gnu/packages/dlang.scm
parent5f5a78872e9fa73836af478835979147ca38ce44 (diff)
downloadguix-22e289a67ab6ce03c84c67c0ea20814ee912f643.tar.gz
gnu: d-tools: Use G-expressions.
* gnu/packages/dlang.scm (d-tools)[arguments]:
Rewrite as G-expressions.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index f80484c908..d987c3bf72 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -29,6 +29,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module ((guix build utils) #:hide (delete which))
   #:use-module (guix build-system gnu)
@@ -62,21 +63,19 @@
         "0c8w373rv6iz3xfid94w40ncv2lr2ncxi662qsr4lda4aghczmq7"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'check) ; There is no Makefile, so there's no 'make check'.
-         (replace
-          'build
-          (lambda _
-            (setenv "CC" ,(cc-for-target))
-            (setenv "LD" ,(ld-for-target))
-            (invoke "ldc2" "rdmd.d")))
-         (replace
-          'install
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-              (install-file "rdmd" bin)))))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)
+               (delete 'check) ; There is no Makefile, so there's no 'make check'.
+               (replace 'build
+                 (lambda _
+                   (setenv "CC" #$(cc-for-target))
+                   (setenv "LD" #$(ld-for-target))
+                   (invoke "ldc2" "rdmd.d")))
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+                     (install-file "rdmd" bin)))))))
     (native-inputs
      (list ldc
            (module-ref (resolve-interface