summary refs log tree commit diff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-06-15 19:53:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-19 02:00:00 +0200
commit5f5a78872e9fa73836af478835979147ca38ce44 (patch)
tree2455a5d67acba375704b853e579ec37414448a97 /gnu/packages/dlang.scm
parentdc8c869724afc0ead3a6020d75b4cee6018de21f (diff)
downloadguix-5f5a78872e9fa73836af478835979147ca38ce44.tar.gz
gnu: d-tools: Fix build.
* gnu/packages/dlang.scm (d-tools)[arguments]: Set target CC and LD
environment variables.
[native-inputs]: Add ld-gold-wrapper.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 799ec7f184..f80484c908 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -62,13 +62,15 @@
         "0c8w373rv6iz3xfid94w40ncv2lr2ncxi662qsr4lda4aghczmq7"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     `(#:phases
        (modify-phases %standard-phases
          (delete 'configure)
          (delete 'check) ; There is no Makefile, so there's no 'make check'.
          (replace
           'build
           (lambda _
+            (setenv "CC" ,(cc-for-target))
+            (setenv "LD" ,(ld-for-target))
             (invoke "ldc2" "rdmd.d")))
          (replace
           'install
@@ -76,7 +78,10 @@
             (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
               (install-file "rdmd" bin)))))))
     (native-inputs
-     (list ldc))
+     (list ldc
+           (module-ref (resolve-interface
+                        '(gnu packages commencement))
+                       'ld-gold-wrapper)))
     (home-page "https://github.com/dlang/tools")
     (synopsis "Useful D-related tools")
     (description