summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-26 22:31:12 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-27 00:49:55 +0100
commit5ee4e91ada104b5e9b73c6f7df733144eafb045d (patch)
treeaa2e0b7c0c21af374e63b3e83272863e10b28154 /gnu/packages/dns.scm
parentc6e99f78f0f8c9d4da11162acd55ec73c8625641 (diff)
downloadguix-5ee4e91ada104b5e9b73c6f7df733144eafb045d.tar.gz
gnu: yadifa: Update to 2.5.3.
* gnu/packages/dns.scm (yadifa): Update to 2.5.3.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b289aa999e..0c2e037b4f 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -875,16 +875,16 @@ served by AS112.  Stub and forward zones are supported.")
 (define-public yadifa
   (package
     (name "yadifa")
-    (version "2.5.1")
+    (version "2.5.3")
     (source
-     (let ((build "10306"))
+     (let ((build "10333"))
        (origin
          (method url-fetch)
          (uri
           (string-append "https://www.yadifa.eu/sites/default/files/releases/"
                          "yadifa-" version "-" build ".tar.gz"))
          (sha256
-          (base32 "051h4pmh9llwj0w6h0v8fl2f146fb26cv3w5an9dmfh845sv6hzr")))))
+          (base32 "1mwy6sfnlaslx26f3kpj9alh8i8y8bf1nbnsdd5j04hjsbavd07p")))))
     (build-system gnu-build-system)
     (native-inputs
      `(("which" ,which)))
@@ -896,15 +896,13 @@ served by AS112.  Stub and forward zones are supported.")
          (add-before 'configure 'omit-example-configurations
            (lambda _
              (substitute* "Makefile.in"
-               ((" (etc|var)") ""))
-             #t))
+               ((" (etc|var)") ""))))
          (add-after 'configure 'omit-spurious-references
            (lambda _
              ;; The many Makefile.in grep this(!) to #define BUILD_OPTIONS.
              (substitute* "config.log"
                (("(=/gnu/store/)[^-]*" _ match)
-                (string-append match "...")))
-             #t)))
+                (string-append match "..."))))))
        #:configure-flags
        (list "--sysconfdir=/etc"
              "--localstatedir=/var"