summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-26 15:42:44 -0500
committerLeo Famulari <leo@famulari.name>2021-12-26 15:52:31 -0500
commit79fe54052f22a6d96a6cea43b3c4e355ca1da86b (patch)
tree1caaff9ecce49d87a372ba45f1a9fee5f91394f8 /gnu/packages/dns.scm
parent3c4c356879542136ee3408be1d7f1c17d8efbb3d (diff)
downloadguix-79fe54052f22a6d96a6cea43b3c4e355ca1da86b.tar.gz
gnu: ldns: Do not depend directly on nss-certs.
If ldns depends on a particular version of nss-certs, the features that use the
certificates will eventually stop working as the certificates expire. Instead,
the certificates should be found at run-time.

* gnu/packages/dns.scm (ldns)[inputs]: Remove nss-certs.
[arguments]: Adjust the value of "--with-ca-path" in #:configure-flags.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 230a888307..4785f890ec 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -40,7 +40,6 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
-  #:use-module (gnu packages certs)
   #:use-module (gnu packages check)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages databases)
@@ -177,8 +176,7 @@ protocol.")
          ;; https://github.com/erikoest/DNS-LDNS.git
          ;; "--with-p5-dns-ldns"
          (string-append "--with-ssl=" #$(this-package-input "openssl"))
-         (string-append "--with-ca-path=" #$(this-package-input "nss-certs")
-                        "/etc/ssl/certs"))
+         (string-append "--with-ca-path=/etc/ssl/certs"))
       #:make-flags
       #~(list
          (string-append "drillbindir=" #$output:drill "/bin")
@@ -193,7 +191,7 @@ protocol.")
     (native-inputs
      (list doxygen perl perl-devel-checklib pkg-config swig))
     (inputs
-     (list libpcap nss-certs openssl python-wrapper))
+     (list libpcap openssl python-wrapper))
     (synopsis "DNS library that facilitates DNS tool programming")
     (description "LDNS aims to simplify DNS programming, it supports recent
 RFCs like the DNSSEC documents, and allows developers to easily create