summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-28 23:51:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-29 01:53:25 +0100
commit0aa217e7600f54cae1d595714bfd5d77d0cab970 (patch)
treeba38e14632b1caffc31f98889131f01020e3536a /gnu/packages/dns.scm
parentec84186fe4c4d88c2fef37c6044d49baca6a8149 (diff)
downloadguix-0aa217e7600f54cae1d595714bfd5d77d0cab970.tar.gz
gnu: libasr: Update to 1.0.3.
* gnu/packages/dns.scm (libasr): Update to 1.0.3.
[arguments]: Replace ‘bootstrap’ and add ‘install-documentation’ phase.
[native-inputs]: Add libtool and remove groff.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index e120983f80..ec4008bf19 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -273,21 +273,33 @@ the two.")
 (define-public libasr
   (package
     (name "libasr")
-    (version "201602131606")
+    (version "1.0.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.opensmtpd.org/archives/"
                            "libasr-" version ".tar.gz"))
        (sha256
-        (base32
-         "18kdmbjsxrfai16d66qslp48b1zf7gr8him2jj5dcqgbsl44ls75"))))
+        (base32 "13fn4sr4vlcx1xijpl26nmnxawyls4lr5q3mi11jdm76f80qxn4w"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'bootstrap
+           ;; ‘GNU build system bootstrapping not needed’, the default lies.
+           (lambda _
+             (invoke "sh" "./bootstrap")))
+         (add-after 'install 'install-documentation
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (install-file "src/asr_run.3"
+                             (string-append out "/share/man/man3"))
+               #t))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
-       ("pkg-config" ,pkg-config)
-       ("groff" ,groff)))
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
     (home-page "https://www.opensmtpd.org")
     (synopsis "Asynchronous resolver library by the OpenBSD project")
     (description