summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-05-16 18:19:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-05-16 18:21:50 +0200
commitc72c10053dfdf76a148725fc3ff6a67c4144b778 (patch)
treea11427a898081e0539f83668234724e1481e66e6 /gnu/packages/dns.scm
parente865e0b959a91b72d4d9193110ee44e24e1929be (diff)
downloadguix-c72c10053dfdf76a148725fc3ff6a67c4144b778.tar.gz
gnu: bind: Update to 9.14.2.
* gnu/packages/dns.scm (isc-bind): Update to 9.14.2.
[source]: Remove patch.
[arguments]: Run only fuzz tests.
* gnu/packages/patches/bind-fix-unused-pk11-ecc-constants.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index ec10254c97..291139ef1b 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -108,7 +108,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
 (define-public isc-bind
   (package
     (name "bind")
-    (version "9.12.4-P1")
+    (version "9.14.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -116,9 +116,7 @@ and BOOTP/TFTP for network booting of diskless machines.")
                     "/bind-" version ".tar.gz"))
               (sha256
                (base32
-                "1if7zc5gzrfd28csc63v9bjwrc0rgvm1x9yx058946hc5gp5lyp2"))
-              (patches
-               (search-patches "bind-fix-unused-pk11-ecc-constants.patch"))))
+                "033zqajnj5ys45g899132xkhh9f0hsh76ffv7302wl166xbjfh0f"))))
     (build-system gnu-build-system)
     (outputs `("out" "utils"))
     (inputs
@@ -163,7 +161,11 @@ and BOOTP/TFTP for network booting of diskless machines.")
          ;;          (system "bin/tests/system/ifconfig.sh up")))
          (replace 'check
            (lambda _
-             (invoke "make" "force-test"))))))
+             ;; XXX Even ‘make force-test’ tries to create network interfaces
+             ;; and fails.  The only working target is the (trivial) fuzz test.
+             (with-directory-excursion "fuzz"
+               (invoke "make" "check"))
+             #t)))))
     (synopsis "An implementation of the Domain Name System")
     (description "BIND is an implementation of the @dfn{Domain Name System}
 (DNS) protocols for the Internet.  It is a reference implementation of those