summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorZheng Junjie <873216071@qq.com>2021-03-21 10:33:52 +0800
committerLudovic Courtès <ludo@gnu.org>2021-03-28 22:30:59 +0200
commit8bd2c50bee40f68b582a4d26bc918baf60e9c36c (patch)
treef0338d0931dc89c24b3996803bd7a923f87a0f6a /gnu/packages/dns.scm
parent673e5276f6b4dda4bfa9dd5bb70220fc8b17abd2 (diff)
downloadguix-8bd2c50bee40f68b582a4d26bc918baf60e9c36c.tar.gz
gnu: hnsd: Update to 1.0.0.
* gnu/packages/dns.scm (hnsd): Update to 1.0.0.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b6f86711a3..37f8c3a6be 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -18,6 +18,7 @@
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 Simon South <simon@simonsouth.net>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1111,20 +1112,17 @@ attempts the update when it has changed.")
     (license license:gpl2+)))
 
 (define-public hnsd
-  ;; There have been no releases yet, hence this commit.
-  (let ((revision "0")
-        (commit "895d89c25d316d18df9d374fe78aae3902bc89fb"))
    (package
      (name "hnsd")
-     (version (git-version "0.0" revision commit))
+     (version "1.0.0")
      (source (origin
                (method git-fetch)
                (uri (git-reference
                      (url "https://github.com/handshake-org/hnsd")
-                     (commit commit)))
+                     (commit (string-append "v" version))))
                (sha256
                 (base32
-                 "0704y73sddn24jga9csw4gxyfb3pnrfnk0vdcph84n1h38490l16"))
+                 "1kdgff8rf8gmvwz2p758ilbjxpvz4xm6z41pa5353asg6xb853bb"))
                (file-name (git-file-name name version))
                (modules '((guix build utils)))
                (snippet
@@ -1161,7 +1159,7 @@ attempts the update when it has changed.")
      (description
       "@command{hnsd} is a @dfn{host name resolver} for the Handshake Naming
 System (HNS) peer-to-peer network.")
-     (license license:expat))))
+     (license license:expat)))
 
 (define-public libmicrodns
   (package