summary refs log tree commit diff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-04 17:41:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-04 17:41:36 +0100
commita351fc83694f436c3bff7cbdef09bd3cc91c74fc (patch)
tree646145378742a6943d7c4dda995fc0fb67f9db32 /gnu/packages/docbook.scm
parent80b63e670ef4fe1fd40a903bcd4ee47a11415bd9 (diff)
parentd1a5b20081c30da7503201df260cf20b8d0ba633 (diff)
downloadguix-a351fc83694f436c3bff7cbdef09bd3cc91c74fc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 4ea586c80a..067ad1c3b0 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -173,7 +173,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
 (define-public dblatex
   (package
     (name "dblatex")
-    (version "0.3.5")
+    (version "0.3.9")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/dblatex/dblatex/"
@@ -181,7 +181,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
                                   version ".tar.bz2"))
               (sha256
                (base32
-                "0h3472n33pabrn8qwggsahkrjx8lybpwlc3zprby3w3w3x5i830f"))))
+                "0pdizc5rjywwzxa1qqhdmba5zr35pbmdwbysalsid7xw87w3kq06"))))
     (build-system python-build-system)
     ;; TODO: Add xfig/transfig for fig2dev utility
     (inputs
@@ -192,6 +192,15 @@ by no means limited to these applications.)  This package provides XML DTDs.")
        ("libxslt" ,libxslt)))           ;for xsltproc
     (arguments
      `(#:python ,python-2               ;'print' syntax
+       ;; Using setuptools causes an invalid "package_base" path in
+       ;; out/bin/.dblatex-real due to a missing leading '/'.  This is caused
+       ;; by dblatex's setup.py stripping the root path when creating the
+       ;; script.  (dblatex's setup.py still uses distutils and thus has to
+       ;; create the script by itself. The feature for creating scripts is one
+       ;; of setuptools' features.)
+       ;; See this thread for details:
+       ;; https://lists.gnu.org/archive/html/guix-devel/2016-12/msg00030.html
+       #:use-setuptools? #f
        #:tests? #f                      ;no 'test' command
        #:phases
        (alist-cons-after