summary refs log tree commit diff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-18 12:38:35 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-19 06:09:01 +0100
commite6711212505f5426a6f5707445b04a14e17e55ee (patch)
tree6b26724de737c37e1de16894bbced0453d5f07e4 /gnu/packages/docbook.scm
parentc2c73f583d401a84e94a1e1e5b61da9c41f15683 (diff)
downloadguix-e6711212505f5426a6f5707445b04a14e17e55ee.tar.gz
gnu: Use HTTPS for docbook.org.
* gnu/packages/docbook.scm (docbook-xml)[home-page, source]: Use HTTPS.
(docbook-xml-4.4, docbook-xml-4.3, docbook-xml-4.2, docbook-xml-4.1.2)
[source]: Likewise.
(docbook-xsl)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index d114e24ee7..098c2b4dfb 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -40,7 +40,7 @@
     (version "4.5")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.docbook.org/xml/" version
+              (uri (string-append "https://www.docbook.org/xml/" version
                                   "/docbook-xml-" version ".zip"))
               (sha256
                (base32
@@ -66,7 +66,7 @@
                      #t))
                  #:modules ((guix build utils))))
     (native-inputs `(("unzip" ,unzip)))
-    (home-page "http://docbook.org")
+    (home-page "https://docbook.org")
     (synopsis "DocBook XML DTDs for document authoring")
     (description
      "DocBook is general purpose XML and SGML document type particularly well
@@ -79,7 +79,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
     (version "4.4")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.docbook.org/xml/" version
+              (uri (string-append "https://www.docbook.org/xml/" version
                                   "/docbook-xml-" version ".zip"))
               (sha256
                (base32
@@ -90,7 +90,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
     (version "4.3")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.docbook.org/xml/" version
+              (uri (string-append "https://www.docbook.org/xml/" version
                                   "/docbook-xml-" version ".zip"))
               (sha256
                (base32
@@ -101,7 +101,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
     (version "4.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.docbook.org/xml/" version
+              (uri (string-append "https://www.docbook.org/xml/" version
                                   "/docbook-xml-" version ".zip"))
               (sha256
                (base32
@@ -112,7 +112,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
     (version "4.1.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://www.docbook.org/xml/" version
+              (uri (string-append "https://www.docbook.org/xml/" version
                                   "/docbkx412.zip"))
               (sha256
                (base32
@@ -174,7 +174,7 @@ by no means limited to these applications.)  This package provides XML DTDs.")
     (native-inputs `(("bzip2" ,bzip2)
                      ("xz" ,xz)         ;needed for repacked tarballs
                      ("tar" ,tar)))
-    (home-page "http://docbook.org")
+    (home-page "https://docbook.org")
     (synopsis "DocBook XSL style sheets for document authoring")
     (description
      "This package provides XSL style sheets for DocBook.")