summary refs log tree commit diff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-10 14:37:53 -0400
committerLeo Famulari <leo@famulari.name>2017-07-10 14:37:53 -0400
commitc8eb2b8c60d954b4522555a5c75b7bb4be5a1a4d (patch)
tree3a2e569e333ccd9265237868d3f46b2d1e04e3a9 /gnu/packages/docbook.scm
parentad22c7185395a52bd90ea5890a2ac79f44d00352 (diff)
parent61adfb00b11cc16a70e60f19fd8e0a838a3ef608 (diff)
downloadguix-c8eb2b8c60d954b4522555a5c75b7bb4be5a1a4d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm34
1 files changed, 32 insertions, 2 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 7a309b0bc9..189ece01ab 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -180,11 +180,41 @@ by no means limited to these applications.)  This package provides XML DTDs.")
                                   version ".tar.bz2"))
               (sha256
                (base32
-                "0pdizc5rjywwzxa1qqhdmba5zr35pbmdwbysalsid7xw87w3kq06"))))
+                "0pdizc5rjywwzxa1qqhdmba5zr35pbmdwbysalsid7xw87w3kq06"))
+              (patches (search-patches "dblatex-remove-multirow.patch"))))
     (build-system python-build-system)
     ;; TODO: Add xfig/transfig for fig2dev utility
     (inputs
-     `(("texlive" ,texlive)
+     `(("texlive" ,(texlive-union (list texlive-latex-amsfonts
+                                        texlive-latex-anysize
+                                        texlive-latex-appendix
+                                        texlive-latex-changebar
+                                        texlive-latex-colortbl
+                                        texlive-latex-eepic
+                                        texlive-latex-eso-pic
+                                        texlive-latex-fancybox
+                                        texlive-latex-fancyhdr
+                                        texlive-latex-fancyvrb
+                                        texlive-latex-float
+                                        texlive-latex-footmisc
+                                        texlive-latex-hyperref
+                                        texlive-latex-jknapltx
+                                        texlive-latex-listings
+                                        texlive-latex-multirow
+                                        texlive-latex-oberdiek
+                                        texlive-latex-overpic
+                                        texlive-latex-pdfpages
+                                        texlive-latex-subfigure
+                                        texlive-latex-titlesec
+                                        texlive-latex-url
+                                        texlive-latex-wasysym
+
+                                        texlive-fonts-amsfonts
+                                        texlive-fonts-ec
+                                        texlive-fonts-rsfs
+                                        texlive-fonts-stmaryrd
+
+                                        texlive-generic-ifxetex)))
        ("imagemagick" ,imagemagick)     ;for convert
        ("inkscape" ,inkscape)           ;for svg conversion
        ("docbook" ,docbook-xml)