summary refs log tree commit diff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 23:29:14 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-10 23:37:52 +0100
commit83cda00bc62d665f05d37d07c78a1c4eab5297f0 (patch)
treebc20a46a8b7672d570fca4cae4783a9f35be7326 /gnu/packages/docker.scm
parentb665dd4a9902b5722b9e06fd89c203e2221b19e0 (diff)
downloadguix-83cda00bc62d665f05d37d07c78a1c4eab5297f0.tar.gz
gnu: docker: Update to 19.03.15 [security fixes].
* gnu/packages/docker.scm (%docker-version): Bump to 19.03.15.
(docker-libnetwork): Bump to 19.03-1.55e924b.
(docker):
[source]: Set git-reference url to 'https://github.com/moby/moby'.
[arguments]<#:phases>: Modify 'delete-failing-tests phase to delete
'signal_linux_test.go'.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index eb092808f6..e9f3e04c8f 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -52,7 +52,7 @@
 
 ;; Note - when changing Docker versions it is important to update the versions
 ;; of several associated packages (docker-libnetwork and go-sctp).
-(define %docker-version "19.03.13")
+(define %docker-version "19.03.15")
 
 (define-public python-docker
   (package
@@ -252,7 +252,7 @@ network attachments.")
   ;; 'hack/dockerfile/install/proxy.installer'. NOTE - It is important that
   ;; this version is kept in sync with the version of Docker being used.
   ;; This commit is the "bump_19.03" branch, as mentioned in Docker's vendor.conf.
-  (let ((commit "026aabaa659832804b01754aaadd2c0f420c68b6")
+  (let ((commit "55e924b8a84231a065879156c0de95aefc5f5435")
         (version (version-major+minor %docker-version))
         (revision "1"))
     (package
@@ -267,7 +267,7 @@ network attachments.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0bli21vn5v7bssw3ydym4jfdjsldhb47fld88kng7d138wl70lkw"))
+                  "19syb3scwiykn44gqfaqrgqv8a0df4ps0ykf3za9xkjc5cyi99mp"))
                 ;; Delete bundled ("vendored") free software source code.
                 (modules '((guix build utils)))
                 (snippet '(begin
@@ -316,11 +316,11 @@ built-in registry server of Docker.")
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/docker/engine")
+             (url "https://github.com/moby/moby")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1mg3jjisdbqrqrrhyslj3715lslial2kcgjrpprb6q63i52963gj"))
+        (base32 "0419iha9zmwlhzhnbfxlsa13vgd04yifnsr8qqnj2ks5dxrcajl8"))
        (patches
         (search-patches "docker-fix-tests.patch"))))
     (build-system gnu-build-system)
@@ -517,6 +517,8 @@ built-in registry server of Docker.")
              (delete-file "runconfig/config_test.go")
              ;; This file uses /var.
              (delete-file "daemon/oci_linux_test.go")
+             ;; Signal tests fail in bizarre ways
+             (delete-file "pkg/signal/signal_linux_test.go")
              #t))
          (replace 'configure
            (lambda _