summary refs log tree commit diff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-10 04:34:57 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-01-10 04:34:57 +0100
commit8b487bf84f3e93883821910148bec6d3dfa80477 (patch)
treeca7bf9a0bd6dbaaa731e8bc927259eb621b7a41a /gnu/packages/docker.scm
parent58adcaa19f152c5c0554103c0ad13e4faf451f68 (diff)
downloadguix-8b487bf84f3e93883821910148bec6d3dfa80477.tar.gz
gnu: containerd: Fix more paths.
* gnu/packages/docker.scm (containerd)[inputs]: Add util-linux.
[arguments]<#:phases>[patch-paths]: Fix more paths.
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 9ff1361954..5aadfe475f 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -194,6 +194,11 @@ Python without keeping their credentials in a Docker configuration file.")
                (string-append "DefaultCommand = \""
                               (assoc-ref inputs "runc")
                               "/sbin/runc\"\n")))
+            (substitute* "vendor/github.com/containerd/continuity/testutil/loopback/loopback_linux.go"
+             (("exec\\.Command\\(\"losetup\"") ; )
+              (string-append "exec.Command(\""
+                             (assoc-ref inputs "util-linux")
+                             "/sbin/losetup\""))) ;)
              #t))
          (replace 'build
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
@@ -206,7 +211,8 @@ Python without keeping their credentials in a Docker configuration file.")
     (inputs
      `(("btrfs-progs" ,btrfs-progs)
        ("libseccomp" ,libseccomp)
-       ("runc" ,runc)))
+       ("runc" ,runc)
+       ("util-linux" ,util-linux)))
     (native-inputs
      `(("go" ,go)
        ("pkg-config" ,pkg-config)))