summary refs log tree commit diff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-22 16:45:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-22 18:01:09 +0200
commitfb76ef8477f189d35c1e91bf026236f5627f3a27 (patch)
treef4984214a0f32d8005c7c067e887bac9d70a29d1 /gnu/packages/documentation.scm
parentbf91e6835d21e3bd7b49bb85b40f61389604c6f7 (diff)
downloadguix-fb76ef8477f189d35c1e91bf026236f5627f3a27.tar.gz
gnu: Remove GCC ICE workarounds.
* gnu/packages/patches/doxygen-gcc-ice.patch,
gnu/packages/patches/mariadb-gcc-ice.patch,
gnu/packages/patches/perf-gcc-ice.patch: Delete files
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/databases.scm (mariadb)[source](patches): Likewise.
* gnu/packages/linux.scm (perf)[source](patches): Likewise.
* gnu/packages/documentation.scm (doxygen)[inputs, arguments]: Likewise.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm15
1 files changed, 1 insertions, 14 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index f533535f03..9425df707c 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -139,23 +139,10 @@ markup) can be customized and extended by the user.")
        ("libxml2" ,libxml2) ; provides xmllint for the tests
        ("python" ,python-2))) ; for creating the documentation
     (inputs
-     `(("bash" ,bash-minimal)
-       ,@(if (string-prefix? "armhf-" (%current-system))
-             `(("gcc-ice-patch" ,@(search-patches "doxygen-gcc-ice.patch")))
-             '())))
+     `(("bash" ,bash-minimal)))
     (arguments
      `(#:test-target "tests"
        #:phases (modify-phases %standard-phases
-                  ;; Work around an ICE that shows up on native compiles for
-                  ;; armhf-linux.
-                  ,@(if (string-prefix? "armhf-" (%current-system))
-                        `((add-after 'unpack 'apply-gcc-patch
-                            (lambda* (#:key inputs #:allow-other-keys)
-                              (let ((patch (assoc-ref inputs "gcc-ice-patch")))
-                                (invoke "patch" "-p1" "--force"
-                                        "--input" patch)))))
-                        '())
-
                   (add-before 'configure 'patch-sh
                               (lambda* (#:key inputs #:allow-other-keys)
                                 (substitute* "src/portable.cpp"