summary refs log tree commit diff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:19:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:02 +0100
commit33c1c4c95fc8311606f1d513a06bc365607d4f6c (patch)
tree5df66bb2e058c4cbd2331023abdad4d1d041b88f /gnu/packages/documentation.scm
parent8b2c4eb5020eff458690f600351b56ed97465db1 (diff)
downloadguix-33c1c4c95fc8311606f1d513a06bc365607d4f6c.tar.gz
gnu: doxygen: Update to 1.8.16.
* gnu/packages/documentation.scm (doxygen): Update to 1.8.16.
[arguments]: Add phase 'remove-git-requirement'.
* gnu/packages/patches/doxygen-test.patch: Adjust for upstream changes.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index eda8ca3368..c512a9803b 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -125,7 +125,7 @@ markup) can be customized and extended by the user.")
 (define-public doxygen
   (package
     (name "doxygen")
-    (version "1.8.15")
+    (version "1.8.16")
     (home-page "http://www.doxygen.nl/")
     (source (origin
              (method url-fetch)
@@ -136,7 +136,7 @@ markup) can be customized and extended by the user.")
                                        ".src.tar.gz")))
              (sha256
               (base32
-               "0p94b4yb6bk2dxzs5kyl82xxgq2qakgbx5yy3ssbbadncb20x75x"))
+               "10iwv8bcz5b5cd85gg8pgn0bmyg04n9hs36xn7ggjjnvynv1z67z"))
              (patches (search-patches "doxygen-test.patch"))))
     (build-system cmake-build-system)
     (native-inputs
@@ -157,6 +157,13 @@ markup) can be customized and extended by the user.")
              '())
        #:test-target "tests"
        #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'remove-git-requirement
+                    (lambda _
+                      ;; TODO: Remove this for > 1.8.16.
+                      (substitute* "cmake/git_watcher.cmake"
+                        (("Git QUIET REQUIRED")
+                         "Git QUIET"))
+                      #t))
                   (add-before 'configure 'patch-sh
                               (lambda* (#:key inputs #:allow-other-keys)
                                 (substitute* "src/portable.cpp"