summary refs log tree commit diff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-08 14:26:42 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-08 15:23:39 +0200
commit849a1399ca46497ad6acc5b11903f345502c02de (patch)
tree5baa10b0f646201e061fad9a58a8456065760529 /gnu/packages/documentation.scm
parent9953685c0985c6cc4481db3e351f1cc1dbf81e8b (diff)
downloadguix-849a1399ca46497ad6acc5b11903f345502c02de.tar.gz
gnu: doxygen: Work around GCC ICE on armhf-linux.
Reported by Mark H Weaver <mhw@netris.org>
at <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=31708#10>.

* gnu/packages/patches/doxygen-gcc-ice.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/documentation.scm (doxygen)[inputs]: Add "gcc-ice-patch"
on armhf-* only.
[arguments]: Add 'apply-gcc-patch' phase on armhf-* only.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index e36200bbab..2ffe541294 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -139,10 +139,23 @@ markup) can be customized and extended by the user.")
        ("libxml2" ,libxml2) ; provides xmllint for the tests
        ("python" ,python-2))) ; for creating the documentation
     (inputs
-     `(("bash" ,bash-minimal)))
+     `(("bash" ,bash-minimal)
+       ,@(if (string-prefix? "armhf-" (%current-system))
+             `(("gcc-ice-patch" ,@(search-patches "doxygen-gcc-ice.patch")))
+             '())))
     (arguments
      `(#:test-target "tests"
        #:phases (modify-phases %standard-phases
+                  ;; Work around an ICE that shows up on native compiles for
+                  ;; armhf-linux.
+                  ,@(if (string-prefix? "armhf-" (%current-system))
+                        `((add-after 'unpack 'apply-gcc-patch
+                            (lambda* (#:key inputs #:allow-other-keys)
+                              (let ((patch (assoc-ref inputs "gcc-ice-patch")))
+                                (invoke "patch" "-p1" "--force"
+                                        "--input" patch)))))
+                        '())
+
                   (add-before 'configure 'patch-sh
                               (lambda* (#:key inputs #:allow-other-keys)
                                 (substitute* "src/portable.cpp"