summary refs log tree commit diff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-08 17:10:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-08 21:56:04 +0100
commitb34c1258515e75bcc73be7911fd7d237db1dd14b (patch)
treeea3f4537a91f2899ff848c0a0890e7e119afecd8 /gnu/packages/documentation.scm
parent23c883ef832d45387bb2a11451411a76be0c034f (diff)
downloadguix-b34c1258515e75bcc73be7911fd7d237db1dd14b.tar.gz
gnu: doxygen: Update to 1.8.17.
* gnu/packages/documentation.scm (doxygen): Update to 1.8.17.
[source](patches): Add doxygen-1.8.17-runtests.patch.
[arguments]: Remove obsolete phase.
* gnu/packages/patches/doxygen-test.patch: Adjust for upstream changes.
* gnu/packages/patches/doxygen-1.8.17-runtests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index c512a9803b..c4a8c0242d 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -125,7 +125,7 @@ markup) can be customized and extended by the user.")
 (define-public doxygen
   (package
     (name "doxygen")
-    (version "1.8.16")
+    (version "1.8.17")
     (home-page "http://www.doxygen.nl/")
     (source (origin
              (method url-fetch)
@@ -136,8 +136,9 @@ markup) can be customized and extended by the user.")
                                        ".src.tar.gz")))
              (sha256
               (base32
-               "10iwv8bcz5b5cd85gg8pgn0bmyg04n9hs36xn7ggjjnvynv1z67z"))
-             (patches (search-patches "doxygen-test.patch"))))
+               "16dmv0gm1x8rvbm82fmjvi213q8fxqxinm75pcf595flya59ific"))
+             (patches (search-patches "doxygen-test.patch"
+                                      "doxygen-1.8.17-runtests.patch"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -157,13 +158,6 @@ markup) can be customized and extended by the user.")
              '())
        #:test-target "tests"
        #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'remove-git-requirement
-                    (lambda _
-                      ;; TODO: Remove this for > 1.8.16.
-                      (substitute* "cmake/git_watcher.cmake"
-                        (("Git QUIET REQUIRED")
-                         "Git QUIET"))
-                      #t))
                   (add-before 'configure 'patch-sh
                               (lambda* (#:key inputs #:allow-other-keys)
                                 (substitute* "src/portable.cpp"