summary refs log tree commit diff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 13:21:03 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commit4250b256d76f774819a77d45b98344a08794a2a4 (patch)
tree66b2e0b829cf1262ef7ca277654c8273b2913109 /gnu/packages/documentation.scm
parent42db0f4e3356d71f4c223402f461e0ed8798c2cd (diff)
downloadguix-4250b256d76f774819a77d45b98344a08794a2a4.tar.gz
gnu: doxygen: Update to 1.9.1.
* gnu/packages/patches/doxygen-1.8.17-runtests.patch,
gnu/packages/patches/doxygen-test.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/documentation.scm (doxygen): Update to 1.9.1.
[source](patches): Remove.
[home-page]: Use HTTPS.
[arguments]: Disable bibtex test with a phase instead of patch.
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index ae8553436e..708d80fe48 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -203,8 +203,8 @@ markup) can be customized and extended by the user.")
 (define-public doxygen
   (package
     (name "doxygen")
-    (version "1.8.17")
-    (home-page "http://www.doxygen.nl/")
+    (version "1.9.1")
+    (home-page "https://www.doxygen.nl/")
     (source (origin
              (method url-fetch)
              (uri (list (string-append home-page "files/doxygen-"
@@ -214,9 +214,7 @@ markup) can be customized and extended by the user.")
                                        ".src.tar.gz")))
              (sha256
               (base32
-               "16dmv0gm1x8rvbm82fmjvi213q8fxqxinm75pcf595flya59ific"))
-             (patches (search-patches "doxygen-test.patch"
-                                      "doxygen-1.8.17-runtests.patch"))))
+               "1lcif1qi20gf04qyjrx7x367669g17vz2ilgi4cmamp1whdsxbk7"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -236,6 +234,12 @@ markup) can be customized and extended by the user.")
              '())
        #:test-target "tests"
        #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'disable-bibtex-test
+                    (lambda _
+                      ;; Disable test that requires bibtex to avoid a
+                      ;; circular dependency.
+                      (for-each delete-file-recursively
+                                '("testing/012" "testing/012_cite.dox"))))
                   (add-before 'configure 'patch-sh
                               (lambda* (#:key inputs #:allow-other-keys)
                                 (substitute* "src/portable.cpp"