summary refs log tree commit diff
path: root/gnu/packages/dunst.scm
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-11-04 15:55:08 -0400
committerChristopher Baines <mail@cbaines.net>2023-11-05 17:57:56 +0000
commitbf6fdf76b0fe19cbf5787795caac8edab6eeb439 (patch)
tree3fad444b91df4ab03346711217e67b14699026a3 /gnu/packages/dunst.scm
parenta482d3d9ba41c914de1a08ac0ef71406925b8a19 (diff)
downloadguix-bf6fdf76b0fe19cbf5787795caac8edab6eeb439.tar.gz
gnu: Remove dunst.scm.
The dunst package is much beter suited to be in wm.scm. This patch deletes
dunst.scm, moves dunst to wm.scm, and removes dunst.scm from the build
process.

* gnu/local.mk (GNU_SYSTEM_MODULES): Remove dunst.scm.
* gnu/packages/dunst.scm: Delete file.
* gnu/packages/wm.scm (dunst): New variable.

Change-Id: I3b074f12f34e14ef1101069ed45ddb33f8d3ea51
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/dunst.scm')
-rw-r--r--gnu/packages/dunst.scm91
1 files changed, 0 insertions, 91 deletions
diff --git a/gnu/packages/dunst.scm b/gnu/packages/dunst.scm
deleted file mode 100644
index ee389098fb..0000000000
--- a/gnu/packages/dunst.scm
+++ /dev/null
@@ -1,91 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2023 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
-;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
-;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages dunst)
-  #:use-module (guix packages)
-  #:use-module (guix gexp)
-  #:use-module (guix git-download)
-  #:use-module (guix build-system gnu)
-  #:use-module (guix utils)
-  #:use-module ((guix licenses) #:prefix license:)
-  #:use-module (gnu packages)
-  #:use-module (gnu packages base)
-  #:use-module (gnu packages freedesktop)
-  #:use-module (gnu packages glib)
-  #:use-module (gnu packages gnome)
-  #:use-module (gnu packages gtk)
-  #:use-module (gnu packages perl)
-  #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages xorg))
-
-(define-public dunst
-  (package
-    (name "dunst")
-    (version "1.9.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/dunst-project/dunst")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "17zrw7jrnlyln81pxw7p4jgvl7j1w1gf488nfskhns6j6dcz90gh"))))
-    (build-system gnu-build-system)
-    (arguments
-     (list
-      #:tests? #f ;no check target
-      #:make-flags #~(list (string-append "CC="
-                                          #$(cc-for-target))
-                           (string-append "PREFIX=" %output)
-                           (string-append "SYSCONFDIR=" %output "/etc")
-                           ;; Otherwise it tries to install service file
-                           ;; to "dbus" store directory.
-                           (string-append "SERVICEDIR_DBUS=" %output
-                                          "/share/dbus-1/services")
-                           "dunstify")
-      #:phases #~(modify-phases %standard-phases
-                   (delete 'configure))))
-    (native-inputs (list pkg-config perl ;for pod2man
-                         which))
-    (inputs (list dbus
-                  (librsvg-for-system) ;for svg support
-                  glib
-                  cairo
-                  pango
-                  libnotify ;for dunstify
-                  libx11
-                  libxscrnsaver
-                  libxinerama
-                  libxrandr
-                  libxdg-basedir
-                  wayland)) ;for wayland support
-    (home-page "https://dunst-project.org/")
-    (synopsis "Customizable and lightweight notification daemon")
-    (description
-     "Dunst is a highly configurable and minimalistic notification daemon.
-It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
-started automatically on the first call via D-Bus.")
-    (license license:bsd-3)))