summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-30 12:21:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-30 12:36:25 +0200
commit5dc5c5ea41fd72b0999c043148615bb2e585fe85 (patch)
treeed3028ec3ba54f2c1dff0b2faf4b05a0cfec8e03 /gnu/packages/ebook.scm
parent6f0ae1439c6c8429d1da7f3c9b9ebf4ba6640a36 (diff)
downloadguix-5dc5c5ea41fd72b0999c043148615bb2e585fe85.tar.gz
gnu: fbreader: Install desktop file.
* gnu/packages/ebook.scm (fbreader)[arguments]: Add phase to remove
hardcoded paths for desktop dir.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 980d574c4b..c3805a7880 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -275,7 +275,13 @@ designed to be used in a generic text renderer.")
                                       (assoc-ref %outputs "out") "/lib"))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure))))
+         (delete 'configure)
+         (add-after 'unpack 'fix-install-locations
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (substitute* "fbreader/desktop/Makefile"
+                 (("/usr") out))
+               #t))))))
     (home-page "https://fbreader.org/")
     (synopsis "E-Book reader")
     (description "@code{fbreader} is an E-Book reader.  It supports the