summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2016-07-26 12:26:25 -0500
committerRoel Janssen <roel@gnu.org>2016-07-27 23:45:16 +0200
commitb111bdb6675297798e38cf07be79660324ca1a56 (patch)
tree06538a736ee4c223baddf327965fbd344aca88c7 /gnu/packages/ebook.scm
parentcad7e6abafc14de220265e09a0fc4bbd96664599 (diff)
downloadguix-b111bdb6675297798e38cf07be79660324ca1a56.tar.gz
gnu: calibre: Update to 2.63.0.
* gnu/packages/ebook.scm (calibre): Update to 2.63.0.
[inputs]: Remove unnecessary imagemagick dependency.
[phases]: Use modify-phases.

* gnu/packages/patches/calibre-drop-unrar.patch: Update
for new version.

Signed-off-by: Roel Janssen <roel@gnu.org>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index d97e869ccf..ad1871688e 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,7 +32,6 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
-  #:use-module (gnu packages imagemagick)
   #:use-module (gnu packages libusb)
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
@@ -61,7 +61,7 @@
 (define-public calibre
   (package
     (name "calibre")
-    (version "2.62.0")
+    (version "2.63.0")
     (source
       (origin
         (method url-fetch)
@@ -70,7 +70,7 @@
                             version ".tar.xz"))
         (sha256
          (base32
-          "15qskfsdg3fy9cpw1m3mccwgn45366yn7lci5kim0fdzpw9pnkna"))
+          "1rwgv6rsmy3ljfwcpv42w203ghngw86s5kzb0yjm1zgsxmas2wh6"))
         ;; Remove non-free or doubtful code, see
         ;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
         (modules '((guix build utils)))
@@ -102,7 +102,6 @@
        ("fontconfig" ,fontconfig)
        ("glib" ,glib)
        ("icu4c" ,icu4c)
-       ("imagemagick" ,imagemagick)
        ("libmtp" ,libmtp)
        ("libpng" ,libpng)
        ("libusb" ,libusb)
@@ -128,16 +127,15 @@
        #:test-target "check"
        #:tests? #f ; FIXME: enable once flake8 is packaged
        #:phases
-         (alist-cons-before
-          'build 'configure
+       (modify-phases %standard-phases
+         (add-before 'build 'configure
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((podofo (assoc-ref inputs "podofo"))
                   (pyqt (assoc-ref inputs "python2-pyqt")))
               (substitute* "setup/build_environment.py"
                 (("sys.prefix") (string-append "'" pyqt "'")))
               (setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
-              (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))))
-          %standard-phases)))
+              (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))))))))
     (home-page "http://calibre-ebook.com/")
     (synopsis "E-book library management software")
     (description "Calibre is an ebook library manager.  It can view, convert