summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <brendan.tildesley@openmailbox.org>2017-05-14 16:36:13 +1000
committerMarius Bakke <mbakke@fastmail.com>2017-05-19 23:49:21 +0200
commitb3399a0985ffdf978918607b24d3147fcb7708e3 (patch)
tree5b51d91ce97cd5ff13cb32906587ccc1e0594ce9 /gnu/packages/ebook.scm
parent29ec0851707f99fdd14b8c06c26759b98046a8f3 (diff)
downloadguix-b3399a0985ffdf978918607b24d3147fcb7708e3.tar.gz
gnu: calibre: Unbundle liberation fonts.
*gnu/packages/ebook.scm (calibre)[source]: Delete liberation .ttf files.
[native-inputs]: Add font-liberation.
[arguments]: Calibre still references the bundled fonts, so we install the
packaged fonts to the directory the bundled fonts would have been.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index e75183185e..800b518064 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -28,6 +28,7 @@
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages databases)
+  #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages glib)
@@ -81,6 +82,7 @@
             (delete-file-recursively "src/calibre/ebooks/markdown")
             (delete-file-recursively "src/unrar")
             (delete-file "src/odf/thumbnail.py")
+            (delete-file-recursively "resources/fonts/liberation")
             (substitute* (find-files "." "\\.py")
               (("calibre\\.ebooks\\.markdown") "markdown"))
             #t))
@@ -91,6 +93,7 @@
     (build-system python-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
+       ("font-liberation" ,font-liberation)
        ("qtbase" ,qtbase) ; for qmake
        ;; xdg-utils is supposed to be used for desktop integration, but it
        ;; also creates lots of messages
@@ -147,7 +150,17 @@
               (substitute* "setup/build_environment.py"
                 (("sys.prefix") (string-append "'" pyqt "'")))
               (setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
-              (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))))))))
+              (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib")))))
+         (add-after 'install 'install-font-liberation
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (for-each (lambda (file)
+                         (install-file file (string-append
+                                             (assoc-ref outputs "out")
+                                             "/share/calibre/fonts/liberation")))
+                       (find-files (string-append
+                                    (assoc-ref inputs "font-liberation")
+                                    "/share/fonts/truetype")))
+             #t)))))
     (home-page "http://calibre-ebook.com/")
     (synopsis "E-book library management software")
     (description "Calibre is an ebook library manager.  It can view, convert