summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorJovany Leandro G.C <bit4bit@riseup.net>2019-07-24 20:35:15 -0500
committerRicardo Wurmus <rekado@elephly.net>2019-07-25 09:23:17 +0200
commit7c0411879b3a393e4a2b082571fc23d4134b182f (patch)
tree92678442425a38fadf93f9fd5b0ae32f1dbb426d /gnu/packages/ebook.scm
parent8172ab2dde425cbd7fb6e633ceff634990acbefb (diff)
downloadguix-7c0411879b3a393e4a2b082571fc23d4134b182f.tar.gz
gnu: Add xchm.
* gnu/packages/ebook.scm (xchm): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index cf424f285d..205dd3c8a7 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -56,7 +56,8 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages wxwidgets))
 
 (define-public chmlib
   (package
@@ -330,3 +331,27 @@ following formats:
 @item XHTML
 @end enumerate")
     (license license:gpl2+)))
+
+(define-public xchm
+  (package
+    (name "xchm")
+    (version "1.30")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/rzvncj/xCHM"
+                                  "/releases/download/"
+                                  version "/xchm-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1865wb3ppmx5y12rqfhv4wri0lfdah41zsfz94xb8gym80m8zac5"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("wxwidgets" ,wxwidgets)
+       ("chmlib" ,chmlib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/rzvncj/xCHM")
+    (synopsis "CHM file viewer")
+    (description "xCHM is a graphical CHM file viewer.  It is a frontend to
+the CHM library CHMLIB.")
+    (license license:gpl2+)))