summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-05-04 02:42:09 +1000
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-05 14:44:19 +0200
commit4e6f8a1442d04a4dd9066c4bda0a3c06cb4af5d3 (patch)
tree85b1bf5144eff5fec566fcfa203a93ff14287fab /gnu/packages/ebook.scm
parentc8e214e80d3bc4d6e63d2be1648fd2ac05eebc1a (diff)
downloadguix-4e6f8a1442d04a4dd9066c4bda0a3c06cb4af5d3.tar.gz
gnu: calibre: Update to 3.41.3.
* gnu/packages/ebook.scm (calibre): Update to 3.41.3.
[inputs]: Replace python2-cssutils by python2-css-parser.
[snippet]: Modify.
* gnu/packages/patches/calibre-use-packaged-feedparser.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove patch.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 99e49bc172..a603519590 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -78,7 +78,7 @@
 (define-public calibre
   (package
     (name "calibre")
-    (version "3.35.0")
+    (version "3.41.3")
     (source
       (origin
         (method url-fetch)
@@ -87,20 +87,16 @@
                             version ".tar.xz"))
         (sha256
          (base32
-          "1gd15wjz4fhcra6d44xiy3hwbyk0miwb66a1pq5yldyy0hlb271z"))
+          "167hhv4wimkjnyfgqkyqmaiixhicbxacy6190gps98jyj4csi8ra"))
         ;; Remove non-free or doubtful code, see
         ;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
         (modules '((guix build utils)))
         (snippet
           '(begin
-            (delete-file-recursively "src/calibre/ebooks/markdown")
             (delete-file "src/odf/thumbnail.py")
             (delete-file-recursively "resources/fonts/liberation")
-            (substitute* (find-files "." "\\.py")
-              (("calibre\\.ebooks\\.markdown") "markdown"))
             #t))
-        (patches (search-patches "calibre-use-packaged-feedparser.patch"
-                                 "calibre-no-updates-dialog.patch"))))
+        (patches (search-patches "calibre-no-updates-dialog.patch"))))
     (build-system python-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -129,7 +125,7 @@
        ("python2-apsw" ,python2-apsw)
        ("python2-chardet" ,python2-chardet)
        ("python2-cssselect" ,python2-cssselect)
-       ("python2-cssutils" ,python2-cssutils)
+       ("python2-css-parser" ,python2-css-parser)
        ("python2-dateutil" ,python2-dateutil)
        ("python2-dbus" ,python2-dbus)
        ("python2-dnspython" ,python2-dnspython)