summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2019-05-05 14:33:35 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-05-05 14:44:21 +0200
commit68435a7f553c1efeab15965129cb249be4595233 (patch)
treeb4254d6ed8ef1d3febf0090ad78540ad7d6088c2 /gnu/packages/ebook.scm
parent7312a7d073fba1b1d0e1951fa93f5b3a66a4354e (diff)
downloadguix-68435a7f553c1efeab15965129cb249be4595233.tar.gz
gnu: calibre: Unbundle python2-odfpy.
* gnu/packages/ebook.scm (calibre)[snippet]: Remove all of src/odf.
[inputs]: Add python2-odfpy.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index ba99ce9316..d281e2fb5d 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -89,13 +89,13 @@
         (sha256
          (base32
           "167hhv4wimkjnyfgqkyqmaiixhicbxacy6190gps98jyj4csi8ra"))
-        ;; Remove non-free or doubtful code, see
+        ;; Unbundle python2-odfpy. 
         ;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
         (modules '((guix build utils)))
         (snippet
           '(begin
-            (delete-file "src/odf/thumbnail.py")
-            #t))
+             (delete-file-recursively "src/odf")
+             #t))
         (patches (search-patches "calibre-no-updates-dialog.patch"
                                  "calibre-remove-test-bs4.patch" ; TODO: fix test.
                                  "calibre-remove-test-sqlite.patch" ; TODO: fix test.
@@ -141,6 +141,7 @@
        ;; python2-msgpack is needed for the network content server to work.
        ("python2-msgpack" ,python2-msgpack)
        ("python2-netifaces" ,python2-netifaces)
+       ("python2-odfpy" ,python2-odfpy)
        ("python2-pillow" ,python2-pillow)
        ("python2-psutil" ,python2-psutil)
        ("python2-pygments" ,python2-pygments)