summary refs log tree commit diff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:11 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:55 +0200
commit955638d8acf65f6296f6f5771508fd13f494a59a (patch)
tree52b94a638308a963d7fb26907efc12685d4009f5 /gnu/packages/elm.scm
parentb6c0f18dee39d0adb2b8e7019e3d7cc5be9f933d (diff)
downloadguix-955638d8acf65f6296f6f5771508fd13f494a59a.tar.gz
gnu: Add elm-debois-elm-dom.
* gnu/packages/elm.scm (elm-debois-elm-dom): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 9d3a58bcb5..d17a3f2487 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -540,3 +540,23 @@ on the @code{marked} project, which focuses on speed.")
 @url{https://todomvc.com,TodoMVC}, a simple to-do--list application used to
 compare front-end web frameworks.")
       (license license:bsd-3))))
+
+(define-public elm-debois-elm-dom
+  (package
+    (name "elm-debois-elm-dom")
+    (version "1.3.0")
+    (source
+     (elm-package-origin
+      "debois/elm-dom"
+      version
+      (base32 "0w4z4w6ip118lk5g80w6mbbfxhfmivbmdkdm6wsmk63x85gscmqx")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-json elm-html elm-core))
+    (home-page "https://package.elm-lang.org/packages/debois/elm-dom/1.3.0")
+    (synopsis "DOM traversal for Elm event-handlers")
+    (description
+     "This package provides a library for reading information off the DOM.
+Use this if you need to discover geometry information (width, position, etc.)
+of rendered elements.")
+    (license license:asl2.0)))