summary refs log tree commit diff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:03 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:53 +0200
commitdfae053d73a5f0c45af86658379c52e3d70dcff7 (patch)
tree62abc17b6ad67055d01deb88bb6b11b02e0a6a97 /gnu/packages/elm.scm
parent951ad86e816d23224e64c46632dc0f06aeb09bec (diff)
downloadguix-dfae053d73a5f0c45af86658379c52e3d70dcff7.tar.gz
gnu: Add elm-bytes.
* gnu/packages/elm.scm (elm-bytes): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 714a49a3dd..ac10bd8672 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -292,3 +292,21 @@ Use it for HTTP and for @dfn{routing} in @acronym{SPAs, single-page apps}.")
      "This package allows you to create Elm programs that run in browsers,
 with access to browser history for @acronym{SPAs, single-page apps}.")
     (license license:bsd-3)))
+
+(define-public elm-bytes
+  (package
+    (name "elm-bytes")
+    (version "1.0.8")
+    (source
+     (elm-package-origin
+      "elm/bytes"
+      version
+      (base32 "0n411j2cyz9m241q6vszfzpq3fraradwal5m0gigp2505mdfpz3x")))
+    (build-system elm-build-system)
+    (propagated-inputs (list elm-core))
+    (home-page "https://package.elm-lang.org/packages/elm/bytes/1.0.8")
+    (synopsis "Work with sequences of bytes in Elm")
+    (description "This package provides an Elm library for working with
+densely packed sequences of bytes, such as @code{ArrayBuffer}, typed arrays,
+and @code{DataView}.")
+    (license license:bsd-3)))