summary refs log tree commit diff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:02 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:53 +0200
commit951ad86e816d23224e64c46632dc0f06aeb09bec (patch)
treebfe4acaf78a5b5bb4eff4171b07b810a6c0920a3 /gnu/packages/elm.scm
parent31ee69721ae33ae883c8adbfd4ac0663ccad4fea (diff)
downloadguix-951ad86e816d23224e64c46632dc0f06aeb09bec.tar.gz
gnu: Add elm-browser.
* gnu/packages/elm.scm (elm-browser): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index d7d11e0d91..714a49a3dd 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -267,3 +267,28 @@ parse existing URLs into nice Elm data structures.
 
 Use it for HTTP and for @dfn{routing} in @acronym{SPAs, single-page apps}.")
     (license license:bsd-3)))
+
+(define-public elm-browser
+  (package
+    (name "elm-browser")
+    (version "1.0.2")
+    (source
+     (elm-package-origin
+      "elm/browser"
+      version
+      (base32 "0863nw2hhbpm3s03lm1imi5x28wwknzrwg2p79s5mydgvdvgwjf0")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-virtual-dom
+           elm-url
+           elm-time
+           elm-json
+           elm-html
+           elm-core))
+    (home-page "https://package.elm-lang.org/packages/elm/browser/1.0.2")
+    (synopsis
+     "Run Elm in browsers")
+    (description
+     "This package allows you to create Elm programs that run in browsers,
+with access to browser history for @acronym{SPAs, single-page apps}.")
+    (license license:bsd-3)))