summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-03-04 01:40:38 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-11 23:12:26 +0100
commit1bc24bbf00e21a26d9eb71e5c89d941812dcdad7 (patch)
treee2fc633e3dc6c0dcdf11c88df0fca4ff503ee6ff /gnu/packages/emacs-xyz.scm
parent6f93b525d3159675478c78541c95452d1b12e5a3 (diff)
downloadguix-1bc24bbf00e21a26d9eb71e5c89d941812dcdad7.tar.gz
gnu: Add emacs-debpaste.
* gnu/packages/emacs-xyz.scm (emacs-debpaste): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 673a490752..543cfaea3d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11376,6 +11376,29 @@ Org-mode.  It features:
 @end itemize\n")
       (license license:gpl3+))))
 
+(define-public emacs-debpaste
+  (package
+    (name "emacs-debpaste")
+    (version "0.1.5")
+    (home-page "https://github.com/alezost/debpaste.el")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference (url home-page)
+                           (commit (string-append "v" version))))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1wi70r56pd5z0x4dp4m58p9asq03j74kdm4fi9vai83vsl2z9amq"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-xml-rpc" ,emacs-xml-rpc)))
+    (synopsis "Manipulate pastes from the Debian Pastezone")
+    (description "Debpaste is an Emacs interface for the Debian Pastezone,
+allowing you to receive, post, and delete pastes.  It communicates with the
+server using XML-RPC.")
+    (license license:gpl3+)))
+
 (define-public emacs-xml-rpc
   (let ((commit "8f624f8b964e9145acb504e4457c9510e87dd93c")
         (revision "1"))