summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-08-11 08:42:12 +0400
committerAndrew Tropin <andrew@trop.in>2023-08-11 09:02:14 +0400
commitad4520b92662e42d7d0b1e648b2068300dbb95c8 (patch)
tree7fb4900d0fde4374b686d9fa33dbafc8d0957178 /gnu/packages/emacs-xyz.scm
parente6c6014f03e26f87898b39e87bc88a3b61c773ca (diff)
downloadguix-ad4520b92662e42d7d0b1e648b2068300dbb95c8.tar.gz
gnu: Add emacs-org-wild-notifier.
* gnu/packages/emacs-xyz.scm (emacs-org-wild-notifier): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d7fbe20b5..11c1a6be67 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37552,6 +37552,31 @@ clipboard and inserts an Org mode link with a title of a page found by the URL
 into the current buffer.")
       (license license:expat))))
 
+(define-public emacs-org-wild-notifier
+  (let ((commit "cdca8be45b80ab52077a915e77c625bc0ad07dd7")
+        (revision "0"))
+    (package
+      (name "emacs-org-wild-notifier")
+      (version (git-version "0.4.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/akhramov/org-wild-notifier.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0k37ac752r5whjha4mf9qg74g65kf71a2dlpl4wlxvdml5v1czw1"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash emacs-alert emacs-async))
+      (license license:gpl3+)
+      (home-page "https://github.com/akhramov/org-wild-notifier.el")
+      (synopsis "Customizable org-agenda notifications")
+      (description
+       "This package provides notification functions for org-agenda."))))
+
 (define-public emacs-flymake-mypy
   (let ((commit "d79e158f9ed3065ab692cd0d4048aac985c4fecd")
         (revision "0"))