summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-12-13 12:37:15 -0600
committerBrett Gilio <brettg@posteo.net>2019-12-13 12:37:15 -0600
commite19a53938875cbe53a00daa0501846e53656d1af (patch)
treecc6a2a69aad78c1902f57e7e5f46cde2e09683ff /gnu/packages/emacs-xyz.scm
parent5f12df7ea6dd8422aaf5b27f07b27897073a65bd (diff)
downloadguix-e19a53938875cbe53a00daa0501846e53656d1af.tar.gz
gnu: emacs-telega: Correct path coding for `ffmpeg`.
* gnu/packages/emacs-xyz.scm (emacs-telega)[arguments]: Continuation of the
  previous patch. Adds a hard-coded path from NAME `ffmpeg-bin` to work around
  issue of ffmpeg not being found on the system PATH.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86e0ad1108..0480b1b33f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20115,14 +20115,20 @@ fish-completion.  It can be used in both Eshell and M-x shell.")
                #t))
            (add-after 'unpack 'telega-paths-patch
              (lambda* (#:key inputs #:allow-other-keys)
-               ;; Hard-code path to `ffplay`.
+               ;; Hard-code paths to `ffplay` and `ffmpeg`.
                (let ((ffplay-bin (string-append (assoc-ref inputs "ffmpeg")
-                                                "/bin/ffplay")))
+                                                "/bin/ffplay"))
+                     (ffmpeg-bin (string-append (assoc-ref inputs "ffmpeg")
+                                                "/bin/ffmpeg")))
                  (substitute* "telega-ffplay.el"
                    (("\\(executable-find \"ffplay\"\\)")
                     (string-append
                      "(and (file-executable-p \"" ffplay-bin "\")"
-                     "\"" ffplay-bin "\")"))))
+                     "\"" ffplay-bin "\")"))
+                   (("\\(executable-find \"ffmpeg\"\\)")
+                    (string-append
+                     "(and (file-executable-p \"" ffmpeg-bin "\")"
+                     "\"" ffmpeg-bin "\")"))))
                ;; Modify telega-util to reflect unique dir name in
                ;; `telega-install-data' phase.
                (substitute* "telega-util.el"