summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-13 01:12:18 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-14 17:42:11 +0200
commita13884dc36c138815c7e9fbee2c1f7e9cfa9de28 (patch)
tree636c52a88013e8c981c2451643e92b866295477c /gnu/packages/emacs-xyz.scm
parent46695dbaacbdd63113b2d4cc85ab0109f5b15f6d (diff)
downloadguix-a13884dc36c138815c7e9fbee2c1f7e9cfa9de28.tar.gz
gnu: Add emacs-el-patch.
* gnu/packages/emacs-xyz.scm (emacs-el-patch): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bc88387482..6aa09d714a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -14986,6 +14986,28 @@ Dash docsets.")
 through Dash docsets.")
       (license license:expat))))
 
+(define-public emacs-el-patch
+  (package
+    (name "emacs-el-patch")
+    (version "2.2.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/raxod502/el-patch")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "18djslz177q6q33y82zmg2v6n9236a76kiqfvxdk4vbqzjbq82f7"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/raxod502/el-patch")
+    (synopsis "Future-proof your Emacs customizations")
+    (description "This package allows for an alternate definition of an Elisp
+function to be specified and for any differences from the original definition
+to be examined using Ediff.")
+    (license license:expat)))
+
 (define-public emacs-semantic-refactor
   ;; The last release, 0.5, was made on 2015-07-26 and there have been 47
   ;; commits since then.