summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-22 21:39:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-22 21:40:09 +0100
commit40cff060fde60848c15c4b9605e92f98bff0b6d2 (patch)
treeac22141eede764a2df104e07283dea36a80f0fb1 /gnu/packages/emacs-xyz.scm
parent497780ad25faf71d3ace39efe7451ef01e353d5b (diff)
downloadguix-40cff060fde60848c15c4b9605e92f98bff0b6d2.tar.gz
gnu: Add emacs-coterm.
* gnu/packages/emacs-xyz.scm (emacs-coterm): New variable.

Change-Id: Ib96078fa906242dd532a0c949de3049b92804891
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b7aa7bd334..ad8c72e97d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
-;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018, 2019 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2015, 2016, 2018, 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Adriano Peluso <catonano@gmail.com>
@@ -3975,6 +3975,30 @@ customizability and asynchronous upgrading.")
 listing type errors via Flycheck, as well as REPL support for Carp.")
       (license license:asl2.0))))
 
+(define-public emacs-coterm
+  (package
+    (name "emacs-coterm")
+    (version "1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/coterm-"
+                           version ".tar"))
+       (sha256
+        (base32 "0ikfm1acdsckflv1hcy9lmssyac2099x2yybhvb6vkghcgy99p00"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat))
+    (home-page "https://repo.or.cz/emacs-coterm.git")
+    (synopsis "Terminal emulation for comint")
+    (description
+     "This package provides terminal emulation for comint.  If the global
+@code{coterm-mode} is enabled, proper terminal emulation will be supported for
+all newly spawned comint processes.  This allows you to use more complex
+console programs such as @code{less} and @code{mpv} and full-screen TUI
+programs such as @code{vi}, @code{top}, @code{htop} or even @code{emacs
+-nw}.")
+    (license license:gpl3+)))
+
 (define-public emacs-counsel-bbdb
   (package
     (name "emacs-counsel-bbdb")