summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-03-11 11:19:21 +0400
committerAndrew Tropin <andrew@trop.in>2023-03-12 08:00:22 +0400
commit7001cc68b6d5785a8dd6aa202d4acbb2ea9364e5 (patch)
treee9634aeb05415e1b21693a0c44d208c3994894aa /gnu/packages/emacs.scm
parent110406dcc3946db74a01379a53c754adadc4849c (diff)
downloadguix-7001cc68b6d5785a8dd6aa202d4acbb2ea9364e5.tar.gz
gnu: emacs-next-pgtk: Inherit from emacs-next-tree-sitter.
Inherit pgtk emacs from tree-sitter to have both features available for
wayland users.  For more details:
https://yhetil.org/guix-devel/87r0txr99u.fsf@inventati.org/T/#u

* gnu/packages/emacs.scm (emacs-next-pgtk): Inherit from
emacs-next-tree-sitter.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm36
1 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e93dd772e4..34de0bf3e4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -420,24 +420,6 @@ languages.")
        (modify-inputs (package-native-inputs emacs)
          (prepend autoconf))))))
 
-(define-public emacs-next-pgtk
-  (package
-    (inherit emacs-next)
-    (name "emacs-next-pgtk")
-    (source
-     (origin
-       (inherit (package-source emacs-next))
-       (patches
-        (append (search-patches "emacs-pgtk-super-key-fix.patch")
-                (origin-patches (package-source emacs-next))))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments emacs-next)
-       ((#:configure-flags flags #~'())
-        #~(cons* "--with-pgtk" #$flags))))
-    (synopsis "Emacs text editor with @code{pgtk} support")
-    (description "This Emacs build implements graphical UI purely in terms of
-GTK.")))
-
 (define-public emacs-next-tree-sitter
   (let ((commit "ac7ec87a7a0db887e4ae7fe9005aea517958b778")
         (revision "0"))
@@ -462,6 +444,24 @@ GTK.")))
       (synopsis "Emacs text editor with @code{tree-sitter} support")
       (description "This Emacs build supports tree-sitter."))))
 
+(define-public emacs-next-pgtk
+  (package
+    (inherit emacs-next-tree-sitter)
+    (name "emacs-next-pgtk")
+    (source
+     (origin
+       (inherit (package-source emacs-next-tree-sitter))
+       (patches
+        (append (search-patches "emacs-pgtk-super-key-fix.patch")
+                (origin-patches (package-source emacs-next-tree-sitter))))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments emacs-next-tree-sitter)
+       ((#:configure-flags flags #~'())
+        #~(cons* "--with-pgtk" #$flags))))
+    (synopsis "Emacs text editor with @code{pgtk} and @code{tree-sitter} support")
+    (description "This Emacs build implements graphical UI purely in terms
+of GTK and supports tree-sitter.")))
+
 (define-public emacs-minimal
   ;; This is the version that you should use as an input to packages that just
   ;; need to byte-compile .el files.