summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2017-11-21 21:55:11 +0300
committerAlex Kost <alezost@gmail.com>2017-11-22 19:40:45 +0300
commit09f7c41d6ce316db9b3ba0cf360f2fdc4b590ace (patch)
treeabbf9093abfbde08de220119f73bd4dfb9190839 /gnu/packages/emacs.scm
parentf61aaaf36c41a7c9c6dd9a7314757f9b371a1707 (diff)
downloadguix-09f7c41d6ce316db9b3ba0cf360f2fdc4b590ace.tar.gz
gnu: emacs-magit-popup: Update for the new source.
'magit-popup' is not a part of 'magit' anymore.

* gnu/packages/emacs.scm (emacs-magit-popup): Update to 2.12.0.
[source]: Update origin URL and file-name.
[home-page]: Update to the new home.
[native-inputs]: Add 'texinfo' to build the info manual.
[arguments]: Add 'make-info' phase.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b79de35bff..cf31f22590 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -434,6 +434,7 @@ on stdout instead of using a socket as the Emacsclient does.")
        ("perl" ,perl)))
     (propagated-inputs
      `(("dash" ,emacs-dash)
+       ;; XXX Add 'magit-popup' dependency for the next release (after 2.11.0).
        ("with-editor" ,emacs-with-editor)))
     (arguments
      `(#:modules ((guix build gnu-build-system)
@@ -544,20 +545,28 @@ support for Git-SVN.")
 (define-public emacs-magit-popup
   (package
     (name "emacs-magit-popup")
-    (version (package-version magit))
+    (version "2.12.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://raw.githubusercontent.com/magit/magit/"
-                    version "/lisp/magit-popup.el"))
-              (file-name (string-append "magit-popup-" version ".el"))
+                    "https://github.com/magit/magit-popup/archive/v"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0w750kwngq63hi9drad3jxldwkg83sldb9w9r2xl2mqm3hm4l8s6"))))
+                "1dnk611f7lww6rb03hk8ijg2jwxx9f26pjfff4bwjmnjz7hnd6vz"))))
     (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'make-info
+           (lambda _
+             (zero? (system* "make" "info")))))))
+    (native-inputs
+     `(("texinfo" ,texinfo)))
     (propagated-inputs
      `(("emacs-dash" ,emacs-dash)))
-    (home-page "https://github.com/magit/magit")
+    (home-page "https://github.com/magit/magit-popup")
     (synopsis "Define prefix-infix-suffix command combos")
     (description
      "This library implements a generic interface for toggling switches and