summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-14 03:25:38 -0500
committerMark H Weaver <mhw@netris.org>2018-02-14 03:42:07 -0500
commit84fe44201b6e61b21d739058920385e3edfcd411 (patch)
tree0d7120f6f826723aa807cab8316c38ca81b87eaf /gnu/packages/emacs.scm
parent02843215d871c501ec5515d5b2589297d8d4a923 (diff)
downloadguix-84fe44201b6e61b21d739058920385e3edfcd411.tar.gz
gnu: magit: Do not set 'magit-git-executable' to absolute file name.
Fixes <https://bugs.gnu.org/30434>.
Reported by Ricardo Wurmus <rekado@elephly.net>.

* gnu/packages/emacs.scm (magit)[arguments]: Do not modify the default value
of 'magit-git-executable'.  Remove "#:modules" and "#:imported-modules".
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7e36ceb6b4..da524f8199 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
 ;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
@@ -450,13 +450,7 @@ on stdout instead of using a socket as the Emacsclient does.")
        ;; XXX Add 'magit-popup' dependency for the next release (after 2.11.0).
        ("with-editor" ,emacs-with-editor)))
     (arguments
-     `(#:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (guix build emacs-utils))
-       #:imported-modules (,@%gnu-build-system-modules
-                           (guix build emacs-utils))
-
-       #:test-target "test"
+     `(#:test-target "test"
        #:tests? #f               ; tests are not included in the release
 
        #:make-flags
@@ -478,10 +472,7 @@ on stdout instead of using a socket as the Emacsclient does.")
          (add-before
           'build 'patch-exec-paths
           (lambda* (#:key inputs #:allow-other-keys)
-            (let ((git  (assoc-ref inputs "git"))
-                  (perl (assoc-ref inputs "perl")))
-              (emacs-substitute-variables "lisp/magit-git.el"
-                ("magit-git-executable" (string-append git "/bin/git")))
+            (let ((perl (assoc-ref inputs "perl")))
               (substitute* "lisp/magit-sequence.el"
                 (("perl") (string-append perl "/bin/perl")))
               #t))))))