summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:55:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:08 +0300
commitdc58633761e72499ca2938ac462bc2e138ab5398 (patch)
tree9d9fa1bbaaaf714f7231447ec48467361eaaf781 /gnu/packages/emacs.scm
parentfb3aeaf7de9182d5300464e54f58181da6b37110 (diff)
downloadguix-dc58633761e72499ca2938ac462bc2e138ab5398.tar.gz
gnu: Add emacs-validate.
* gnu/packages/emacs.scm (emacs-validate): New public variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ed5d19497c..33bafe6b8e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8337,3 +8337,22 @@ arXiv, Google Scholar, Library of Congress, etc.
 using @kbd{M-up} or @kbd{M-down} if a region is marked, it will move the
 region instead.")
     (license license:gpl3+)))
+
+(define-public emacs-validate
+  (package
+    (name "emacs-validate")
+    (version "1.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/Malabarba/validate.el"
+                                  "/archive/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "125mbd111f1h1baw0z3fzm48y1bvaigljyzvvnqgrn0shxbj0khg"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Malabarba/validate.el")
+    (synopsis "Emacs library for scheme validation")
+    (description "This Emacs library provides two functions that perform
+schema validation.")
+    (license license:gpl3+)))