summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2017-06-24 13:36:11 +0300
committerArun Isaac <arunisaac@systemreboot.net>2017-06-25 19:24:18 +0530
commit1a80e4d7fc718bc6a7295ab6f7ab5ddb13dabc74 (patch)
tree1cb3d0065e0b67cf039fdd75b2e37a34081a8830 /gnu/packages/emacs.scm
parenta80c7aeee2aec5219ffac66b35312d53b4187eed (diff)
downloadguix-1a80e4d7fc718bc6a7295ab6f7ab5ddb13dabc74.tar.gz
gnu: Add emacs-which-key.
* gnu/packages/emacs.scm (emacs-which-key): New variable.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 08bda5a665..ecb6fed6aa 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4939,3 +4939,36 @@ displays results pretty-printed in XML or JSON with @code{restclient-mode}")
 @item dired-tagsistant
 @end itemize\n")
       (license license:gpl3+))))
+
+(define-public emacs-which-key
+  (package
+    (name "emacs-which-key")
+    (version "3.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/justbur/emacs-which-key/archive/v"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0zc9yivdkbxmcllhlbbcvsbj8g8nzzgs0xib488s08p4s0l7xs8m"))
+       (file-name (string-append name "-" version ".tar.gz"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'check
+           (lambda _
+             (zero? (system* "emacs" "--batch" "-L" "."
+                             "-l" "which-key-tests.el"
+                             "-f" "ert-run-tests-batch-and-exit")))))))
+    (home-page "https://github.com/justbur/emacs-which-key")
+    (synopsis "Display available key bindings in popup")
+    (description "@code{emacs-which-key} is a minor mode for Emacs that
+displays the key bindings following your currently entered incomplete command
+(a prefix) in a popup.  For example, after enabling the minor mode if you
+enter C-x and wait for the default of 1 second, the minibuffer will expand
+with all of the available key bindings that follow C-x (or as many as space
+allows given your settings).")
+    (license license:gpl3+)))