summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-20 17:32:42 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-31 16:13:09 +0100
commit8f50634ba44d29a401ab9f6fc636be0299c7f28b (patch)
tree59445479ac709ece473f62473eae6bcf0af982dd /gnu/packages/emacs.scm
parentc907beec92d02a430360a95dc392fd08a792116e (diff)
downloadguix-8f50634ba44d29a401ab9f6fc636be0299c7f28b.tar.gz
gnu: Add emacs-stream.
* gnu/packages/emacs.scm (emacs-stream): New varaible.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 2c76b46e54..1f4035a61f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3320,3 +3320,21 @@ This package contains the library runtime.")
     (description "This package provides an Emacs major mode for
 editing nginx config files.")
     (license license:gpl2+)))
+
+(define-public emacs-stream
+  (package
+    (name "emacs-stream")
+    (version "2.2.0")
+    (home-page "https://github.com/NicolasPetton/stream")
+    (source
+     (origin
+       (method url-fetch)
+       (file-name (string-append name "-" version ".tar.gz"))
+       (uri (string-append home-page "/archive/"version ".tar.gz"))
+       (sha256
+        (base32 "03ql4nqfz5pn55mjly6clhvc3g7x2d28kj7mrlqmigvjbql39xxc"))))
+    (build-system emacs-build-system)
+    (synopsis "Implementation of streams for Emacs")
+    (description "This library provides an implementation of streams for Emacs.
+Streams are implemented as delayed evaluation of cons cells.")
+    (license license:gpl3+)))