summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/embedded.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
downloadguix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
 Conflicts:
	doc/guix.texi
	gnu/local.mk
	gnu/packages/admin.scm
	gnu/packages/base.scm
	gnu/packages/chromium.scm
	gnu/packages/compression.scm
	gnu/packages/databases.scm
	gnu/packages/diffoscope.scm
	gnu/packages/freedesktop.scm
	gnu/packages/gnome.scm
	gnu/packages/gnupg.scm
	gnu/packages/guile.scm
	gnu/packages/inkscape.scm
	gnu/packages/llvm.scm
	gnu/packages/openldap.scm
	gnu/packages/pciutils.scm
	gnu/packages/ruby.scm
	gnu/packages/samba.scm
	gnu/packages/sqlite.scm
	gnu/packages/statistics.scm
	gnu/packages/syndication.scm
	gnu/packages/tex.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
	gnu/packages/xml.scm
	guix/build-system/copy.scm
	guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 0458ed5f13..87c572ba0f 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -32,6 +32,7 @@
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix svn-download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -1092,6 +1093,41 @@ the Raspberry Pi chip.")
       (description "This package provides @code{gcc} for VideoCore IV,
 the Raspberry Pi chip."))))
 
+(define-public imx-usb-loader
+  ;; There are no proper releases.
+  (let ((commit "30b43d69770cd69e84c045dc9dcabb1f3e9d975a")
+        (revision "0"))
+    (package
+      (name "imx-usb-loader")
+      ;; For the version string, see IMX_LOADER_VERSION in imx_loader.h.
+      (version (git-version "0.2pre" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/boundarydevices/imx_usb_loader")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1jdxbg63qascyl8x32njs9k9gzy86g209q7hc0jp74qyh0i6fwwc"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list #:test-target "tests"
+             #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                                  (string-append "prefix=" #$output))
+             #:phases #~(modify-phases %standard-phases
+                          (delete 'configure))))
+      (native-inputs (list pkg-config))
+      (inputs (list libusb))
+      (home-page "https://github.com/boundarydevices/imx_usb_loader")
+      (synopsis "USB and UART loader for i.MX5/6/7/8 series")
+      (description "This utility downloads and executes code on Freescale
+i.MX5/i.MX6/i.MX7 and Vybrid SoCs through the Serial Download Protocol (SDP).
+Depending on the board, there is usually some kind of recovery button to bring
+the SoC into serial download boot mode; check the documentation of your
+hardware.  The utility support USB and UART as serial link.")
+      (license license:lgpl2.1+))))
+
 (define-public python-libmpsse
   (package
     (name "python-libmpsse")
@@ -1676,3 +1712,38 @@ provides command line tools for Mbed OS to detect Mbed enabled devices
 connected by USB, checkout Mbed projects and perform builds amongst other
 operations.")
     (license license:asl2.0)))
+
+(define-public ts4900-utils
+  ;; There are no proper release nor tag; use the latest commit.
+  (let ((revision "0")
+        (commit "e10a12f8050d1d1229e711c7cfab8a0d5d93ee58"))
+    (package
+      (name "ts4900-utils")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/embeddedTS/ts4900-utils")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1vr8i425qijbwgbc10av3wr35p3x11wy6y442w0ja0yny7si8wp8"))))
+      (build-system gnu-build-system)
+      (native-inputs (list autoconf automake))
+      (home-page "https://github.com/embeddedTS/ts4900-utils")
+      (synopsis "Utilities for the TS-4900 board family")
+      (description "This package contains utilities useful for boards of the
+TS-4900 family.  The included commands are:
+@itemize @code
+@item adc8390
+@item gpioctl
+@item isl12020rtc
+@item load_fpga
+@item nvramctl
+@item tshwctl
+@item tsmicroctl
+@item tsmicroupdate
+@item tssilomon
+@end itemize")
+      (license license:bsd-2))))