summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-11 13:50:30 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:23 +0200
commit77ee97628a2d126a31f60d4ca8fafa70a66be804 (patch)
tree9565b13511fe4bd981d5990903612e8e0e02fe34 /gnu/packages/embedded.scm
parentf9f2198d82f6aa7147700bed3f9d42a93201d620 (diff)
downloadguix-77ee97628a2d126a31f60d4ca8fafa70a66be804.tar.gz
gnu: binutils: Use gexps.
This is the result of applying ‘guix style -S arguments’ and making
small adjustments.

* gnu/packages/base.scm (binutils)[arguments]: Use gexps.
(binutils-2.33, binutils-gold): Likewise.
* gnu/packages/commencement.scm (binutils-mesboot0, binutils-mesboot1)
(binutils-boot0, binutils-final): Likewise.
* gnu/packages/cross-base.scm (cross-binutils*): Adjust accordingly.
* gnu/packages/embedded.scm (make-propeller-binutils): Use gexps.
* gnu/packages/make-bootstrap.scm (%binutils-static): Use gexps.

Change-Id: I59cbe29760784b09e6d4e80beca9153cb9b495a7
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 1da4141519..bee65663b6 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -746,16 +746,17 @@ with a layered architecture of JTAG interface and TAP support.")
                     "0w0dff3s7wv2d9m78a4jhckiik58q38wx6wpbba5hzbs4yxz35ck"))
                   (patches '())))
         (arguments
-         `(;; FIXME: For some reason there are many test failures.  It's not
-           ;; obvious how to fix the failures.
-           #:tests? #f
-           #:phases
-           (modify-phases %standard-phases
-             (add-after 'unpack 'chdir
-               (lambda _ (chdir "binutils") #t)))
-           ,@(substitute-keyword-arguments (package-arguments xbinutils)
-               ((#:configure-flags flags)
-                `(cons "--disable-werror" ,flags)))))
+         (list
+          ;; FIXME: For some reason there are many test failures.  It's not
+          ;; obvious how to fix the failures.
+          #:tests? #f
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-after 'unpack 'chdir
+                (lambda _ (chdir "binutils") #t))
+              #$@(substitute-keyword-arguments (package-arguments xbinutils)
+                   ((#:configure-flags flags)
+                    #~(cons "--disable-werror" #$flags))))))
         (native-inputs
          `(("bison" ,bison)
            ("flex" ,flex)