summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-19 11:10:41 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:58 -0400
commitd95db23cb1d657bf017681afc1a674e41c1aa7d8 (patch)
tree06f275925060a12b173bbf9e56ea948ce32afcb9 /gnu/packages/embedded.scm
parentef4473051e82d94560b38ca76e9a0ad4b7f410ae (diff)
downloadguix-d95db23cb1d657bf017681afc1a674e41c1aa7d8.tar.gz
gnu: mbed-tools: Update to 7.53.0 and relax click version requirement.
* gnu/packages/embedded.scm (mbed-tools): Update to 7.53.0.
[phases]{relax-requirements}: New phase.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index de8d2944bc..9257eea3b0 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2020, 2021, 2022 Simon South <simon@simonsouth.net>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2022 Mathieu Othacehe <othacehe@gnu.org>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1647,17 +1648,22 @@ whereas kdmx creates pseudo-ttys.")
 (define-public mbed-tools
   (package
     (name "mbed-tools")
-    (version "7.49.1")
+    (version "7.53.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "mbed-tools" version))
        (sha256
         (base32
-         "07w1h1093xzpg8agw9hjhki5856mam2c6f3q7jb2866n82cihkg9"))))
+         "0gdmyxy97bqr9bmkg90v3axmrr2db734nwzq2l05z84x9qiarc9i"))))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'relax-requirements
+           (lambda _
+             (substitute* "setup.py"
+               (("\"Click>=7.1,<8\"")
+                "\"Click>=7.1\""))))
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?