summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-24 10:16:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-24 10:16:07 +0200
commit02aab3df21d4f43076f4d34c600cb55dff448dab (patch)
treebc10b172b2c7bbf1e4d4a0c350261d497613e572 /gnu/packages/embedded.scm
parent9be1f2b77c93034378938a08f4b02a693a305913 (diff)
downloadguix-02aab3df21d4f43076f4d34c600cb55dff448dab.tar.gz
gnu: spin2cpp: Don't use unstable tarball.
* gnu/packages/embedded.scm (spin2cpp)[source]: Download using git-fetch.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index b35c0a663c..43075603c8 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -827,13 +827,14 @@ upload binaries to a Parallax Propeller micro-controller.")
     (name "spin2cpp")
     (version "3.6.4")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/totalspectrum/spin2cpp/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/totalspectrum/spin2cpp")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "05qak187sn0xg7vhrxw27b19xhmid1b8ab8kax3gv0faavzablfw"))))
+                "0wznqvsckzzz4hdy2rpvj6jqpxw4yn7i0c7zxfm6i46k8gg9327b"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ;; The tests assume that a micro-controller is connected.