summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-14 13:12:54 -0500
committerLudovic Courtès <ludo@gnu.org>2020-12-21 17:47:36 +0100
commit0b8c90b65acd439668edd828796d91ca0fca3ee6 (patch)
tree1b9dc92a2c3586c8b57255696ce3650886121479 /gnu/packages/embedded.scm
parentc11fedf63c005059eda0d6c4cafee12908fc42e2 (diff)
downloadguix-0b8c90b65acd439668edd828796d91ca0fca3ee6.tar.gz
gnu: sdcc: Update to 4.0.0.
* gnu/packages/embedded.scm (sdcc): Update to 4.0.0.
[native-inputs]: Add zlib.
[description]: Update to match new version.
* gnu/packages/patches/sdcc-disable-non-free-code.patch: Update to match new
version.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index a7643deb97..bda7195f1d 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -41,6 +41,7 @@
   #:use-module ((gnu packages base) #:prefix base:)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages dejagnu)
   #:use-module (gnu packages flex)
@@ -1466,7 +1467,7 @@ and Zilog Z80 families, plus many of their variants.")
 (define-public sdcc
   (package
     (name "sdcc")
-    (version "3.7.0")
+    (version "4.0.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1474,7 +1475,7 @@ and Zilog Z80 families, plus many of their variants.")
                     "/" version "/sdcc-src-" version ".tar.bz2"))
               (sha256
                (base32
-                "13llvx0j3v5qa7qd4fh7nix4j3alpd3ccprxvx163c4q8q4lfkc5"))
+                "042fxw5mnsfhpc0z9lxfsw88kdkm32pwrxacp88kj2n2dy0814a8"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -1490,7 +1491,8 @@ and Zilog Z80 families, plus many of their variants.")
        ("boost" ,boost)
        ("flex" ,flex)
        ("python-2" ,python-2)
-       ("texinfo" ,texinfo)))
+       ("texinfo" ,texinfo)
+       ("zlib" ,zlib)))
     (arguments
      `(;; GPUTILS is required for the PIC ports, but the licensing status of
        ;; some of the files contained in its distribution is unclear (see
@@ -1508,9 +1510,9 @@ and Zilog Z80 families, plus many of their variants.")
     (home-page "http://sdcc.sourceforge.net")
     (synopsis "C compiler suite for 8-bit microcontrollers")
     (description "SDCC is a retargetable, optimizing Standard C compiler suite
-that targets 8-bit microcontrollers in the Intel MCS-51 (8051), Motorola
-68HC08, STMicroelectronics STM8, and Zilog Z80 families, plus many of their
-variants.")
+that targets 8-bit microcontrollers in the Intel MCS-51 (8051); Motorola
+68HC08; Padauk PDK13, PDK14 and PDK15; STMicroelectronics STM8; and Zilog Z80
+families, plus many of their variants.")
     (license (list license:gpl2+
                    license:gpl3+
                    license:lgpl2.0+