summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-11-16 14:54:04 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-11-16 15:02:48 +0100
commitf2c6375449d085393eb538240200840ff242a743 (patch)
tree97694ea5dfca9c4a6ee6126783ff914c44bd0fce /gnu/packages/embedded.scm
parent455daf46adadf47582f57ff2ec8898b927913793 (diff)
downloadguix-f2c6375449d085393eb538240200840ff242a743.tar.gz
gnu: gcc-vc4: Update to commit 0fe4b83897341742f9df65797474cb0feab4b377.
* gnu/packages/patches/gcc-6-fix-buffer-size.patch: New file.
* gnu/packages/patches/gcc-6-fix-isl-includes.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/embedded.scm (gcc-vc4): Update to commit
0fe4b83897341742f9df65797474cb0feab4b377.
[source]: Add the patches from above.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 3a64c75109..89d4aaf97e 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1024,8 +1024,8 @@ the Raspberry Pi chip.")
       (home-page "https://github.com/puppeh/vc4-toolchain/"))))
 
 (define-public gcc-vc4
-  (let ((commit "165f6d0e11d2e76ee799533bb45bd5c92bf60dc2")
-        (xgcc (cross-gcc "vc4-elf" #:xbinutils binutils-vc4)))
+  (let ((commit "0fe4b83897341742f9df65797474cb0feab4b377")
+        (xgcc (cross-gcc "vc4-elf" #:xgcc gcc-6 #:xbinutils binutils-vc4)))
     (package (inherit xgcc)
       (name "gcc-vc4")
       (source (origin
@@ -1039,7 +1039,10 @@ the Raspberry Pi chip.")
                                           "-checkout"))
                 (sha256
                  (base32
-                  "13h30qjcwnlz6lfma1d82nnvfmjnhh7abkagip4vly6vm5fpnvf2"))))
+                  "0kvaq4s0assvinmmicwqp07d0wwldcw0fv6f4k13whp3q5909jnr"))
+                (patches
+                 (search-patches "gcc-6-fix-buffer-size.patch"
+                                 "gcc-6-fix-isl-includes.patch"))))
       (native-inputs
         `(("flex" ,flex)
           ,@(package-native-inputs xgcc)))