summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2016-09-19 23:23:38 +0300
committerRicardo Wurmus <rekado@elephly.net>2016-10-16 11:53:07 +0200
commitdbc3c34ea0f992a00c7856d4ce39aa1585b759cf (patch)
tree7c794144b530d431e3a4e8d9d339c6501a892b83 /gnu/packages/embedded.scm
parentf4a4b854e0d8a3d8bb333592806de8aeaca5c68c (diff)
downloadguix-dbc3c34ea0f992a00c7856d4ce39aa1585b759cf.tar.gz
gnu: Add arm-none-eabi-gcc-6.
* gnu/packages/embedded.scm (gcc-arm-none-eabi-6): New variable.
* gnu/packages/patches/gcc-6-arm-none-eabi-multilib.patch: New file.
* gnu/packages/patches/gcc-6-cross-environment-variables.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add the patches.
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 24eeef9fa7..96d63d57af 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Theodoros Foradis <theodoros.for@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,6 +28,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages cross-base)
   #:use-module (gnu packages flex)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages texinfo))
 
@@ -97,6 +99,17 @@
               (variable "CROSS_LIBRARY_PATH")
               (files '("arm-none-eabi/lib"))))))))
 
+(define-public gcc-arm-none-eabi-6
+  (package
+    (inherit gcc-arm-none-eabi-4.9)
+    (version (package-version gcc-6))
+    (source (origin (inherit (package-source gcc-6))
+                    (patches
+                     (append
+                      (origin-patches (package-source gcc-6))
+                      (search-patches "gcc-6-cross-environment-variables.patch"
+                                      "gcc-6-arm-none-eabi-multilib.patch")))))))
+
 (define-public newlib-arm-none-eabi
   (package
     (name "newlib")