summary refs log tree commit diff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-12 19:08:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-12 19:08:47 +0300
commit6921e95ae80daad8cbd08fccaf2516298c196149 (patch)
tree159066de8e207d56bc47de48068e394d4ff35d18 /gnu/packages/emulators.scm
parenta9e7d6564b42cf62bab73eef3cf2bc99851ef379 (diff)
downloadguix-6921e95ae80daad8cbd08fccaf2516298c196149.tar.gz
gnu: mame: Fix renaming executable.
* gnu/packages/emulators.scm (mame)[arguments]: Only rename 'mame64' to
'mame' when 'mame64' exists.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a7c9104683..1687c9652f 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1235,7 +1235,8 @@ play them on systems for which they were never designed!")
                            (find-files "keymaps" ".*LINUX\\.map")))
                (let ((fonts (string-append share "/fonts")))
                  (install-file "uismall.bdf" fonts))
-               (rename-file "mame64" "mame")
+               (when (file-exists? "mame64")
+                 (rename-file "mame64" "mame"))
                (install-file "mame" (string-append out "/bin")))
              #t))
          (add-after 'install 'install-documentation