summary refs log tree commit diff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-29 08:29:48 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-12-29 08:29:48 +0100
commit8168404f3ca0b024709bcab9ade343a8b867f5c9 (patch)
treee8d5df314c8f8dcd63f0248933fc290cec0979dd /gnu/packages/emulators.scm
parentdd8356e3c6a27b4d6655a3d0aea2d52410f6edc4 (diff)
downloadguix-8168404f3ca0b024709bcab9ade343a8b867f5c9.tar.gz
gnu: mame: Update to 0.205.
* gnu/packages/emulators.scm (mame): Update to 0.205.
[arguments]: Remove unnecessary fix.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 991599a394..2d21f1246a 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1186,7 +1186,7 @@ play them on systems for which they were never designed!")
 (define-public mame
   (package
     (name "mame")
-    (version "0.204")
+    (version "0.205")
     (source
      (origin
        (method git-fetch)
@@ -1196,7 +1196,7 @@ play them on systems for which they were never designed!")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0yn63v2f1xlksfnvbxc5p5zpc7ps044m1kf69jhzbfirx953slsi"))
+         "1q5z18rlmas598fxga8jr2d6xdngdzjab49xfy4hffdmlq624lw7"))
        (modules '((guix build utils)))
        (snippet
         ;; Remove bundled libraries.
@@ -1223,14 +1223,6 @@ play them on systems for which they were never designed!")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
-         ;; Prevent compilation error: ‘atan’ is not a member of ‘std’.  Also
-         ;; fixed upstream in fec1cde5a40e197d4ed4314bf58b9e66e84e1631.
-         (add-after 'unpack 'fix-build
-           (lambda _
-             (substitute* "src/mame/video/xavix.cpp"
-               (("#include \"logmacro.h\"")
-                "#include \"logmacro.h\"\n#include <cmath>"))
-             #t))
          (add-after 'build 'build-documentation
            (lambda _ (invoke "make" "-C" "docs" "man" "info")))
          (replace 'install