summary refs log tree commit diff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2021-02-17 19:50:33 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-02-28 11:12:38 +0800
commit9c30f26b8dca1be5b0cdaeea04a3484905cfd4f2 (patch)
tree8f42cbec0145cd3558f485204077915d10a9d56b /gnu/packages/emulators.scm
parent6a67f4430f971c447b30d4b3a6f7db569d1cec37 (diff)
downloadguix-9c30f26b8dca1be5b0cdaeea04a3484905cfd4f2.tar.gz
gnu: retroarch: Update to 1.9.0.
* gnu/packages/emulators.scm (retroarch): Update to 1.9.0.
[source]: Remove 'retroarch-disable-online-updater.patch' and snippet.
Add 'retroarch-LIBRETRO_DIRECTORY.patch'.
[native-search-paths]: New field.
* gnu/packages/patches/retroarch-disable-online-updater.patch: Remove file.
* gnu/packages/patches/retroarch-LIBRETRO_DIRECTORY: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 6c044e3397..dcbffa0a28 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1273,7 +1273,7 @@ as RetroArch.")
 (define-public retroarch
   (package
     (name "retroarch")
-    (version "1.8.1")
+    (version "1.9.0")
     (source
      (origin
        (method git-fetch)
@@ -1282,18 +1282,9 @@ as RetroArch.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0y7rcpz7psf8k3agsrq277jdm651vbnn9xpqvmj2in1a786idya7"))
+        (base32 "1n0dcv85vqrdr79psnf009hi4r2mvsgsjbghrrc9pm5g7ywwwcvp"))
        (patches
-        (search-patches "retroarch-disable-online-updater.patch"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Don't suggest using the Online Updater if available: it never
-           ;; is.  This disables translation of this particular message.
-           (substitute* (find-files "menu/drivers" "\\.c$")
-             (("msg_hash_to_str\\(MSG_MISSING_ASSETS\\)")
-              "\"Warning: Missing assets, go get some\""))
-           #t))))
+        (search-patches "retroarch-LIBRETRO_DIRECTORY.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -1328,7 +1319,9 @@ as RetroArch.")
                        '("--enable-neon" "--enable-floathard")
                        '())
                  (string-append "--prefix=" out)
-                 (string-append "--global-config-dir=" etc)
+                 ;; Non-free software are available through the core updater,
+                 ;; disable it.  See <https://issues.guix.gnu.org/38360>.
+                 "--disable-update_cores"
                  "--disable-builtinminiupnpc")))))))
     (inputs
      `(("alsa-lib" ,alsa-lib)
@@ -1354,6 +1347,11 @@ as RetroArch.")
      `(("pkg-config" ,pkg-config)
        ("wayland-protocols" ,wayland-protocols)
        ("which" ,which)))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "LIBRETRO_DIRECTORY")
+            (separator #f)              ; single entry
+            (files '("lib/libretro")))))
     (home-page "https://www.libretro.com/")
     (synopsis "Reference frontend for the libretro API")
     (description