summary refs log tree commit diff
path: root/gnu/packages/enchant.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-28 04:03:23 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 00:33:01 +0200
commitc1d59b3c2a88427aa268a405116a01958db84a5b (patch)
tree9e12254dc11afe5304b563491a5e798b60533a6d /gnu/packages/enchant.scm
parent9a59b29411e2f007a6ba32b88d3b6f50bd6c1f45 (diff)
downloadguix-c1d59b3c2a88427aa268a405116a01958db84a5b.tar.gz
gnu: enchant: Update to 2.2.3.
* gnu/packages/enchant.scm (enchant): Update to 2.2.3.
[arguments]: Add "--enable-relocatable" to #:configure-flags.
[native-inputs]: Add UNITTEST-CPP.
(enchant-1.6): New public variable.
* gnu/packages/fcitx.scm (fcitx)[inputs]: Change ENCHANT to ENCHANT-1.6.
* gnu/packages/gnome.scm (gspell): Likewise.
* gnu/packages/mate.scm (pluma): Likewise.
* gnu/packages/gtk.scm (gtkspell3)[propagated-inputs]: Likewise.
[inputs]: Remove duplicate ENCHANT.
Diffstat (limited to 'gnu/packages/enchant.scm')
-rw-r--r--gnu/packages/enchant.scm50
1 files changed, 36 insertions, 14 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index c3f75ccf2e..0392a709e2 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,29 +20,32 @@
 (define-module (gnu packages enchant)
   #:use-module (gnu packages)
   #:use-module (gnu packages aspell)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages pkg-config)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (guix licenses))
+  #:use-module (guix licenses)
+  #:use-module (srfi srfi-1))
 
 (define-public enchant
   (package
     (name "enchant")
-    (version "1.6.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri
-          (string-append "http://www.abisource.com/downloads/" name "/" version
-                         "/" name "-" version ".tar.gz"))
-        (sha256
-          (base32 "0zq9yw1xzk8k9s6x83n1f9srzcwdavzazn3haln4nhp9wxxrxb1g"))))
-
+    (version "2.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/AbiWord/enchant/releases"
+                                  "/download/v" version "/enchant-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0v87p1ls0gym95qirijpclk650sjbkcjjl6ssk059zswcwaykn5b"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:configure-flags '("--disable-static")))
+     '(#:configure-flags '("--disable-static"
+                           ;; Tests require a relocatable build.
+                           "--enable-relocatable")))
     (inputs
      `(("aspell" ,aspell)))   ;; Currently, the only supported backend in Guix
     (propagated-inputs        ;; is aspell. (This information might be old)
@@ -49,8 +53,8 @@
      `(("glib" ,glib)))
     (native-inputs
      `(("glib:bin" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
-
+       ("pkg-config" ,pkg-config)
+       ("unittest-cpp" ,unittest-cpp)))
     (synopsis "Multi-backend spell-checking library wrapper")
     (description
       "On the surface, Enchant appears to be a generic spell checking library.
@@ -63,3 +67,21 @@ library.  Everything should \"just work\" for any and every definition of \"just
 working\".")
     (home-page "https://abiword.github.io/enchant/")
     (license lgpl2.1+)))
+
+;; Some packages are not ready for the 2.x API yet, so we keep this version
+;; around.  The library and executables of Enchant 2 have been designed not to
+;; conflict with 1.x, so it's OK if both end up in the same profile.
+(define-public enchant-1.6
+  (package
+    (inherit enchant)
+    (version "1.6.0")
+    (arguments '(#:configure-flags '("--disable-static")))
+    (native-inputs (alist-delete "unittest-cpp"
+                                 (package-native-inputs enchant)))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://www.abisource.com/downloads/enchant/"
+                                  version "/enchant-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0zq9yw1xzk8k9s6x83n1f9srzcwdavzazn3haln4nhp9wxxrxb1g"))))))